تنظیم ارسال ایمیل در صورت قطع شدن پینگ دستگاه در میکروتیک

تنظیم ارسال ایمیل در صورت قطع شدن پینگ دستگاه در میکروتیک

استفاده از NETWATCH

با سلام یکی از مواردی که بسیار کارایی و مانیتورینگ شبکه را افزایش میدهد استفاده از netwatch جهت پی بردن به اختلالات بوجود امده در کوتاه ترین زمان در شبکه میباشد.

این سرویس به ما کمک میکند تا در زمانی که یک رویداد درون شبکه اتفاق می افتد یک مکانیزم فعال و یا غیر فعال شود مثلا میتوان با یک اسکریپت به سرور ها دستور داد تا خاموش شوند و یا یک ایمیل جهت اطلاع رسانی به مدیر شبکه ارسال شود

استفاده از این سرویس که بصورت رایگان در میکروتیک وجود دارد به ما در زمینه هایی مختلفی در کنترل شبکه کمک خواهد کرد

سناریو ارسال ایمیل در زمان قطعی یک دستگاه

در این سناریو ای پی یکی از دستگاهها در هنگام قطعی از طریق netwach بررسی میگردد و در صورت رویداد بوجود آمده یک ایمیل از طریق سرویس جیمیل تعریف شده از طریق میکروتیک ارسال میگردد

مراحل کار به شرح زیر است:
1-ابتدا از طریق منوی tools>Email  تنظیمات ایمیل را شبیه تصویر زیر تنظیم نمایید

آدرس ای پی پابلیک و پورت روی 587 ور tls را yes تنظیم کنید و یوزر و پسورد آدرس جیمیل را ئارد کنید

mail mikrotik shabakehonline

 

2- در این مرحله وارد منوی tools>netwatch شده و آدرس دستگاه مورد نظر را در تب اول واردکنید

میتوانید از منوی timeout مقدار زمانی را که netwatch ای پی را چک میکند تعیین کنید

netwatch shabakehonline1

3-در تب on و یا off میتوانید اسکریپتی که مربوط به رویداد هست را انتخاب کنید

اگر بر روی on اسکریپت بنویسید به معنی ان هست که در هنگام برقرار شدن پینگ دستگاه این اسکریپت فعال میشود در این سناریو داخل منوی down اسکریپت زیر را قرار میدهیم تا در صورت قطعی پینگ یک ایمل برای ما ارسال گردد

netwatch shabakehonline2

کد اسکریپت به شرح زیر است:

:local EmailAdd “youremail”
:local CurDate [/system clock get date]
:local CurTime [/system clock get time]
:local HostName “bargh Ghat shod”
:local HostIP “192.168.1.50”
:log info “$HostName $HostIP is Down”
:log info “Email is sent to youremail”

/tool e-mail send to=”$EmailAdd” subject=”Host \”$HostName\” is UP at $CurTime $CurDate” body=”Host \”$HostName($HostIP)\” is up at $CurTime.

آموزش  failover در میکروتیک ، اینترنت بکاپ در میکروتیک ، Failover mikrotik آموزش
Netwatch در میکروتیک، راه اندازی 2 اینترنت در میکروتیک ،Fail over میکروتیک ، اسکریپت های کاربردی میکروتیک

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

*

code

×

سلام!

 

× سوالی دارید؟ با ما چت کنید